Animations playing on android but not Iphone


I have a project that I’ve built for android and it all works fine. When we take the project and build it for iphone however the main characters animations do not play.

The animation files all seem to exist.
The character has the animations available in the inspector with correct frame numbers.
Debug output shows the animation starts, plays and ends normally.
visually the skinned mesh stays in the t-pose.
The other skinned mesh in the scene plays it’s animation correctly and i can see it.
This happens on the mac editor and iphone builds but not on android or pc builds on my machine.

I have tried everything I can think of.
Ive checked the blend weights in the settings.
Ive reimported everything.
Ive checked the animation import settings.
Ive tried playing the animations just using “play” instead of “blend”

Banging my head against the wall here, any help REALLY appreciated.

Sounds really strange.
Since I hear you have pretty much run out of things to try, why don´t you try copying the animations out of the fbx, which I assume they are in now, and create a separate external animation file out of them. Then assign the animations back to the prefabs.

The testing cycle IS fun, my boss has the mac and im working remotely through source control :confused:

I also zipped up the whole project and sent it to him btw to eliminate SVn from the equation.

Maybe ill ask him to test the model independently good idea.