Animator component makes Character fall a bit

I am doing some Mecanim animation but I am getting stuck. The animator component makes the model fall a bit (lets call this “the fall”). If I disable it, then the character does not fall.

Check out the Video (YouTube) explaining the issue.

"the fall"

Animator Component

If I add a rigidbody and a capsule collider (see image below for structure). It completely falls through the floor if the “the fall” makes the bounds go below the plane. If I disable the animator component and leave the rigidbody and collider, the models feet stop on the floor plane (how it should act).

The Colliders empty has a mimic child script that is attached to the spine but this has no effect and is the same as putting the empty as a child of the spine.

Structure

The animator controller just has a empty state in it set as default.

What in the animator component makes the character fall?

TLDR;

  • Don’t use a empty state in your Animator Controller
  • Use a static Idle animation as your basic “empty” building block state

The empty state will cause your character to fall.


The problem enlies in having the empty state in the Animator Controller or in my case, not generating a separate avatar for the idle_br animation.

I had a separate fbx (of the same model) with the idle_br pose and had the Avatar Definiton set as Copy from other Avatar, the value being my normal Master Chief generated avatar. I thought it was logical to copy avatar since it is the same model, rig, and bone structure. Instead you should Create From This Model and configure a new avatar.

If you take the robot model/rig for example from Unity’s Mecanim tutorial and create the Mecanim avatar, automap, and enforce pose. Then make a new Avatar Controller with a empty state and set it as the animator controller. Then you will see the robot fall and go into a knees bent and arms out pose.

Robot empty animator controller pose

Try making sure that the mimic child script does so in the LateUpdate() method.

It looks like the sort of problem that having ApplyRootMotion enabled would cause but you clearly dont have it on so try enabling it just to see.

Also how do you calculate your gravity? If it is calculated using the model there might be a problem.

Try right click inspector → debug → unclick Allow Constant Clip Sam…,