Animator transitions bug?,Animator transition bug?

Hi,

I am very new to using unity, but have tried first looking for a solution with no luck. I am following a tutorial on basic animations and I’m finding that once an animation state is used for a transition, I can no longer select “make transition” to another state as I see in the tutorial. In the image I provided there is a transition from ‘walk’ to ‘idle’ but in right-clicking ‘walk’ I no longer have the option to make a transition to ‘jump’…am I doing something wrong? I also noticed that when a transition is made to any of the states the inspector window (as shown in the image) is completely blank, what is happening here?

I struggled with this issue as well (which only seemed to be a problem if an animation state already had two transitions associated with it). But it finally worked if I selected multiple states at once, then right-clicked the one I wanted the transition for. Also, after selecting “make transition”, it would not show the connector until clicking on another state. Hope that helps!

I am using 2020.3.32f1 and having this same problem.
The better workaround was to click on the … of the inspector window and select debug.

Same issue here, any help ?

I experience exactly the same issue @Foolishnostalgia. Even selecting Entry node with mouse after adding 2 transitions is not possible (the blue frame quickly flashes and disappears; some other states can be selected if total input and output transition count is less than 3 in my case) but there is no way to add new Transition once total number is 2. I spent a lot of time googling but found no solution.

Also when selecting different state as default the orange arrow does not change to new state. Tried reloading assets, deleting Animator and recreating, rebooting, etc. Possibly some cache corruption issue as I am sure I could create multiple transitions yesterday…

I am using 2020.3.31f1.1696.2 Personal (built 14Mar2022)