AnimatorOverrideController problem

Hi everybody,

I’m using AnimatorOverrideController in order to change some clips in my animator, but when I do this the animator is automatically reset, so the Idle animation plays instead of keeping the current one. I tried to save the current animation hash before override and force play after but it stills show the Idle animation for 1 or 2 frames…

Does anyone know a solution about that ? I’m on a free version I can’t use a second layer with sync option :-/

Late to the party, but take a look at this thread:

As far as I can tell you need to force an update of the animator after restoring the state.

Note that I have been trying this myself on 5.1.1 and restoring the state doesn’t seem to be working anymore (the Animator seems to be in a bad state after changing the clips in the override, reporting 0 layers and 0 parameters). If anybody knows what’s going on, I’m interested.

Edit: problem solved in the thread referenced above. Animator needs to be spun once before setting back the saved state.