Anonymous Sign not working! Not generating Session Token!

Hi, everyone!

Trying to build my first multiplayer using NetCode and all that new good stuff. But, every time I have the same error when trying to authenticate anonymously. Printing "AnalyticsSessionInfo.identityToken" displays an empty string!

Errors:
[Authentication]: Token has expired. [...]
Unity.Services.Authentication.JwtDecoder:smile:ecode (string,Unity.Services.Authentication.WellKnownKey[ ]) (at Library/PackageCache/com.unity.services.authentication@2.1.1/Runtime/Utilities/Jwt/JwtDecoder.cs:51)
Unity.Services.Authentication.AuthenticationServiceInternal:CompleteSignIn ...
-----:::::
RequestFailedException: Failed to decode and verify access token.
Unity.Services.Authentication.AuthenticationServiceInternal.CompleteSignIn (Unity.Services.Authentication.SignInResponse response, System.Boolean enableRefresh) (at Library/PackageCache/com.unity.services.authentication@2.1.1/Runtime/AuthenticationServiceInternal.cs:504)...

private async Task Authenticate()
    {
        Debug.Log($"Starting authentication...");
        await UnityServices.InitializeAsync();

        Debug.Log($"Signing In Anonymously Async...");
        await AuthenticationService.Instance.SignInAnonymouslyAsync();
    }

I know this post is a bit old, but I'm running into a similar issue. When I'm trying to authenticate on my machine, everything works as intended. But when I send a build of the game to my friend, he gets the exact same error

[Authentication]: Token has expired.
RequestFailedException: Failed to decode and verify access token.

We are pretty desperate at this point and we even tried installing unity on his pc and writing a short authentication script there. It still didn't work for him. Has anyone found a way to fix it?

im here for the same problem :(

Hey everyone!
Prior to the release of Unity Authentication 2.5.0 the SDK would validate the expiration date on the access token on the SDK and would not take into account different timezones and fail the validation. Since the release of 2.5.0 the SDK no longer validates the expiration on the access token on the SDK and leaves the validation to the backend.
I can see the first report was on version 2.1.0. If you're still having issues would you be able to update to the a version after 2.5.0?