Anti-gravity is turning on when it shouldn't

Hello. I recently imported the character package into my Unity game and I ran it to see if my character could move. My character did not move, which is another question entirely, but I noticed another strange occurrence. Attached below is a picture of my tables and monitors floating away into space as if affected by some sort of anti-gravity. This is weird because it is only happening with some of my tables and some of my monitors while all of the tables and monitors are identical except for the rotation angle.

Does anybody have any idea as to how to fix it? I have rigidbody on all of the monitors and tables, but I turned gravity off because they had a tendency to fall through the floor as if it didn’t even exist. I also have mesh colliders on all of them, and no scripts or extra code at all (I am just in the layout stage of the game). Comment if you need any extra information that could lead to the solution.

@Dabber1337 Try setting IsKinematic on your Rigidbody to true. Also you should avoid using MeshColliders as they could cause performance issues depending on the amount of vertices on your mesh.