Anyone tried it with KDE/Plasma?

I know official support is only for GNOME but I just wanted to see if anyone else had this issue with Plasma and found a workaround. I'm on Kubuntu 20.04 LTS. I have this weird behavior where if I click a menu tab in the editor the dropdown will persist on the display as per the attached image. If I click away and then mouse over the region with the dropdowns they'll disappear so it's not a huge deal, just annoying.

6676783--764845--persisted_dropdowns.png

I'm also on Kubuntu 20.04 LTS and I don't have this problem.
Are you using the global menu bar ? It is known not to work well with Unity, although the cause is not known.

As far as I can tell I don't have that enabled (doesn't seem to be a default). Beyond installing some themes I haven't modified much on the KDE-side. I'm using an nvidia GTX 1070 as my GPU with driver 455.45.01, not sure if that's relevant at all. Should also note that this is the only application I have that exhibits this behavior.

I also have this, I tested several distros and in all of them this bug occurred. Besides Unity the only place that occurs (that I tested) is on Microsoft Edge, so I think it is some incompatibility with the video card that should be resolved soon (or in a long time). I use XFCE in Linux Mint 20.

My PC's video card is much worse than yours, I thought it was a problem because it is old:
ATI Radeon 3200

[quote]
I also have this, I tested several distros and in all of them this bug occurred.
[/quote]
May I ask which distros you tried and with which desktop environments? Did this bug also occurred on Gnome3? Also, which version of Unity are you using?


Almost all the distros I tested didn't use a gnome-based interface (Or gnome itself), I don't remember if this occurred in Linux Mint Cinnamon, I'll try to see that today. The only version in which this does not seem to occur is the 2018, but it's experimental (I've already tested 2019 and 2020).

[quote]
I'll try to see that today. The only version in which this does not seem to occur is the 2018, but it's experimental (I've already tested 2019 and 2020).
[/quote]

Interesting, just tried the experimental version 2018 from Unity Hub and this works fine on my Kubuntu install - just as I would expect. I've tested 2020.2.1f1, 2020.1.17f1, and 2019.4.17f1 and those all have the same problem - but 2018.4.30f1 seems fine.

I don't know if this is related, but these are the only settings I changed into my KDE and I never had any problem with Unity (I used both 2019.4 and 2020.1, I also didn't have any problem on Gnome3 on the same hardware). Maybe try these on your end and see if that changes anything?

6698527--768727--Screenshot_20210106_002317.png

Also not sure if this is related, but have you configured a theme for GTK applications in your settings? There is a (easy to miss) button called Configure GNOME/GTK Application Style into the Application Style section in KDE settings. I remember this is one of the first thing I changed after installing KDE. Since Unity uses GTK then maybe it has an impact. But I don't have any certainty about that.

I managed to solve in XFCE changing from Xfwm4 to Xfwm4 + Compositing.
6699040--768832--upload_2021-1-7_12-38-21.jpg

6699040--768835--upload_2021-1-7_12-39-0.png

6699040--768838--upload_2021-1-7_12-39-15.png

1 Like

Thanks guys, it looks like my compositor in KDE was disabled due to some previous kwin-related error. Forcing re-enabling it fixed the issue in the 2020 version of Unity!


Can you please tell us more? What exactly have you done, and what is the behavior that you're getting?