apk build issues

8982358--1235962--captura.jpg Does anyone know why this happens? When I try to build Unity it stays like this for hours and hours and it doesn't complete. I've already downloaded the SDK and NDK on my own, I've tried using what comes with the installation... Nothing works. I need to get my app to run, but it crashes and won't leave this screen. It does not build the APK.

How to troubleshoot build failures:

First, make a blank project with a single blank scene and prove that it builds successfully.

If the blank project does NOT build, go fix your Unity installation or your other tools, such as Android SDK, NDK, JDK, etc. It may even be necessary to change to a different version of Unity3D. It is generally best to stay with LTS versions of Unity3D.

Until you can build a blank project to the target platform, don't fiddle with anything else.

Once you can build a blank project, now bisect the problem by bringing over parts of your current project and building it one subsystem at a time, perhaps stubbing things out that might trigger compiler errors.

Most often things that prevent building are third-party libraries such as Firebase.

Once you identify the subsystem, go to the documentation for it and make sure you are doing it correctly.

It may also be helpful to work through a tutorial or two for whatever subsystem is making the build fail.

Android build not building:

Recently (circa July 2022) there have been reports of Unity's installer failing to install the Android Tools.

https://discussions.unity.com/t/887277

Here was how I brought up Unity2020.3.41 and the Android SDK 31 on October 30, 2022:

https://discussions.unity.com/t/891017/7

Android Gradle errors and other related stuff:

https://discussions.unity.com/t/901712/2

I had trouble with an ad plugin that was causing the apk to do something like this. Could be a plugin you installed. You can try Deleting everything but Assets folder and Project Settings folder and try to see what types of errors you have to solve. Usually last Plugin you introduced is the culprit to this.

Could be days before you find out what it is. It's easier to rebuild it and start placing plugins back into place to see what will break it.