Apple Mach-O Linker (Id) Error...

I see this posted all the time and can never find a clear solution (most go unresolved). It’s such a pain because it seems so random. I released a simple iOS game last year and it went perfectly smooth, and now I want to release a new version with very minor changes and I’m getting the mach-o linker error. I’ve even tried removing the changes and rebuilding the original version, but I’m still getting the same errors. I’ve also downloaded the newest versions of unity and xcode (not the beta). I’ve tried a lot of the suggestions I’ve read that were given to issues similar to mine, so if someone could take a look at these errors and give me any more advice, I’d really appreciate it. It’s frustrating but of course I appreciate what Unity does to make everything so easy.

Here’s the list of warnings and errors I’m getting:

  1. make sure your deployment target is 8.0 +
  2. make sure in build setting enable module=yes and enable bitcode=no (show in screenshotalt text)

if not solve problem by these step , then tell me which advertise plugins are you using in your game?


There is a problem with the latest version of GoogleMobileAds unity plugin. Use old version Instead. I used an older version, probably 3.1.3 and it worked just fine !