Application.persistentDataPath is empty

Application.persistentDataPath is “” in some devices. I´m doing a simple:

	Debug.Log(Application.persistentDataPath));

And in some iOS devices and PCs, it comes out as “”. In other devices, it works fine. Has anyone experienced this before? It´s getting my users pretty upset, as some of them just cannot save anything they do in my app.

Unity 3.5.6f4

Seems like the best approach is to avoid Application.persistantDataPath altogether, and write a Java plugin to get the Internal storage directory directly from the OS. Seems that the persistantDataPath can change based on if you have an SD card inserted or a USB cable plugged in anyway, not to mention why it returns an empty string for some users in particular situations.

Hi,I‘ve got the same problem,and then I slove it by rebuild the "ProjectSettings.asset"file,It worked.

My problem was solved when I noticed the carriage return (/r) character in the ProductName of my project. Look here:
https://forum.unity.com/threads/app…-string-on-some-machines.384000/#post-3604512

Try using this instead :

System.Environment.GetFolderPath(System.Environment.SpecialFolder.ApplicationData)