Applying a Proper Mesh Collider to a Blender Import

I have been creating some 3D elements using Blender and I can't seem to get the mesh collider setting right. My models will render in my scene, but the physics is applied incorrectly. When I apply a mesh collider to my model as one unit, the mesh appears to be rotated 90 degrees from the actual object. What should I do in order to create a mesh that fits my model? Should the collider be applied to the object as a whole, or to an individual part of the object? Any pointers on importing from Blender or just applying physics colliders to custom objects would be greatly appreciated.

I think I found a relatively easy way to fix the problem without having to go back into blender and re-positioning the object. When the asset is imported as a prefab, under the inspector expand the (FBXImporter) component. Checking the "Generate Colliders" box applies mesh colliders to the individual parts of the object, and the entire object has a new collider that is oriented correctly with its position.

One thing I have noted though is that my object still has a habit of falling through a created terrain, especially on an incline when the object is rolling and a narrower part of the object contacts the terrain. I think that this however is something different from my original problem, so it might be easily fixed by creating a thicker mesh. Can anyone check me on this?

Blender doesn't use the same axis convention as Unity. Why don't you just use the import setting, "Meshes have colliders"? That automatically orients the collider properly.

where is that import setting? EDIT i figured it out dood, when u bake the scale and rotation, it doesn't apply it the same direction aka 90degrees wrong. so go into blender and open up your problem object, rotate it 90 degrees in the opposite direction (if collider is facing down in unity, face it up in blender) then in the 3d view header, go object | clear/apply | apply scale/rot to obdata. after you have done that rotate your object back to its original position and save.

problem solved !!

(well it did for me any way heh)

I think to make a new Prefab works. in my case, I imported objects from blender and then added its mesh models to my new GameObject and made a prefab then applied collider.
worked for me :slight_smile: