AR Camera Background not showing up (ARKit 3.1.0 prev.1 + Unity URP 7.1.5)

Hello Community!

I have setup a new project for an AR app and the problem is simple:

I cannot see the camera image in the background.

Specs:
iPad Pro 11" (iOS 13.1)
iMac (Late 2013) updated to macOS Catalina (10.15.1)
XCode 11.2.1
Unity 2019.3.0b12
AR Foundation, Subsystems & ARKit XR Plugin: 3.1.0 preview.1 (since I need ObjectRecognition)

Project settings:
- Universal Render Pipeline (URP 7.1.5), RenderPipelineAsset created as described here
- Color Space: Linear (tried also Gamma)
- Graphics API: Metal (no auto)
- Tried also with custom material (new material with ARKit XR Plugin contained ARKitURPBackground.shader without success (it appears magenta in the material preview)

Scene (started from URP project):
- (Disabled) Main Camera
- Directional Light
- Post-process Volume
- (Disabled) Example Assets
- AR Session
- AR Session Origin
- - AR Camera
- MyModel

Building the app in Unity & XCode succeeds, even if there are some errors like:
"Exception: Calling TargetGuidByName with name="Unity-iPhone" is deprecated..." or s.t. similar as
"Anti-aliasing cannot be set after RenderTexture was defined"

At Runtime it is asking for camera access, localisation works, since I can see my model staying in place when moving the tablet.

I tried the same setup with the Standard 3D Render Pipeline (keeping everything else) and I can see the camera image in the background.

Does somebody have the same problem, is it just because of all the new versions or did I get somethin wrong?

Thank you very much for your help!

1 Like

Woohoo! Funnily, it took me two days of testing before asking you and there was one last thing I tried 2 minutes after posting, which is the solution (at least for me) which I want to share here:

In addition to setting the custom UniversalRenderPipelineAsset just in Project Settings -> Graphics, I found that in Project Settings -> Quality there is another field for a UniversalRenderPipelineAsset defaulted to the quality settings high, medium or low. I dropped the custom asset also there (see image attached) et voilá, the camera image is visible.

Maybe somebody can elaborate on this? Is that the right way or should it work differently?

Best, André

5245382--523829--Screen Shot 2019-12-04 at 15.45.52.png

4 Likes

Thank you very much, this saved me potentially days of frustration.

I wonder why this isn't included as a step in this guide: https://docs.unity3d.com/Packages/com.unity.xr.arfoundation@3.0/manual/ar-camera-background-with-scriptable-render-pipeline.html

1 Like

andre-tms
Thank you so much, the answer you wrote helped me !!

Totally replicated in unity 2020.1.7f1, ARFoundation 3.1.5 and ARFoundation-Samples 3.1 branch.
You guys saved me time. I did this setup before with success so I refused to do a google search for like 1 hour, definitely I needed to. It wasn't needed like some months ago.
Definitely ARFoundation guys need to put this steps into their manual.

All setup steps in one place:
https://forum.unity.com/threads/arfoundation-4-uwrp7-3-unity2019-4-not-working-black-screen-and-no-tracking.915527/#post-6374280

2 Likes

Same problem here.
Camera feed doesn't show on AR Kit using AR Foundation.
In my case the issue was using URP.
AR Foundation v 4.0.12.
AR Kit version v 4.0.12.

I followed @KyryloKuzyk post instructions.
In additional I changed all "Rendering" with URP reference in all the Quality Levels, not only the one used currently.
The issue was solved.

1 Like