AR Foundation "black screen"

Cannot get AR Foundation to work on a Galaxy S7 with Android 8. When I build, all I get is a black screen (or color if I change the AR Camera background color).

I’ve tried 2019.1 along with the 2019.2 Beta and samples (latest versions). I’ve tried LWRP and Legacy. I can drop in a cube in front of the AR Camera and I see the cube and the background color (so it renders), but moving the phone doesn’t change camera position and the phone camera feed is not passing through.

I am not prompted for camera permissions (and setting permission manually doesn’t help). I’ve tried every tutorial that I can find, changed every setting I know to change. Nothing works. No error in logcat dump that I can see. Any ideas/suggestions would be great…

Wow… so, it turns out, you MUST have ARCore installed on the device from the Play Store. Something that happens automatically for “AR Required” store apps. I did not see this instruction anywhere, but once I installed that on the Galaxy, it started “working.”

Detected planes kept floating off for no apparent reason (Google’s “AR Elements” doesn’t do this, so I don’t suspect the hardware – although it still takes forever to find a plane). So the only thing functioning correctly for me is the face tracking and image tracking samples.

Oh well. I guess I’ll try again once the software matures.