AR Tracked Image Manager descriptor is null

I’m working on an AR project that needs to add reference images during runtime

When I tried to do trackedImageManager.CreateRuntimeLibrary(), I got this error: “No image tracking subsystem found. This usually means image tracking is not supported.”

So I check if the image manager supports mutable libraries with trackedImageManager.descriptor.supportsMutableLibrary

But it return an error that said trackedImageManager.descriptor is null

I tried to google why the descriptor is null but no answer for this

I also download the latest version of the AR Foundation Sample from Unity to see what I did wrong but the descriptor of AR Tracked Image Manager from that project also return null

I’m using:

AR Foundation version 4.1.9

AR Subsystems version 4.1.9

ARCore version 4.1.9

ARKit version 4.1.9

In case anyone got this problem in the future

You will need to select the ARCore in the plugin settings. I’m using unity version 2019.4.20f1 but I think the later version may be the same or only different a little.

You will need to go to: File → Build Settings → Player Settings → XR Plug-in Management → Select the platform you are using (in my case it is Android) → Check the ARCore plugin

I have the same error. I checked the ARCorePlugin and is enabled, Any other idea? Thanks in advance !,I have the same error, I checked what you mentioned but I have the ARCore plgin enabled. Any other idea ??