ARCore is included even disabled, which forcing minSdkVersion to be 19.

I’ve already set the Minimum API Level to 16 (Android 4.1), and didn’t tick ARCore support.

However, when I build, it failed with:

uses-sdk:minSdkVersion 16 cannot be smaller than version 19 declared in

It’s from a temporily made AndroidManifest.xml having such code:

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android=""
    android:versionName="1.0" >

        android:targetSdkVersion="19" />


Clearly it’s from ARCore…

Why this manifest is included while I didn’t enable ARCore? I don’t want to change to API 19 unless very necessary. Any idea?

P.S. Unity 2017.3.1f1

After deleting ~/.android/build-cache/ and restart, it works…

Probably it’s some caching error thing.