ARFoundation Plane Detection, Horizontal positioning problem.

I a m working on an AR App where I have Horizontal Plane Detection and the app is supposed to add a plane on a horizontal surface and then disable plane detection. however, my plane appears hovering in the air instead of the floor (which I am detecting).

How can I make the plane appear ON the floor?

I am working with AR Foundation and Unity 2019.3.

Following the answers here helped me for anyone else who was looking!