ARFoundation: screen tearing on iOS, but not On Android

Hello everyone !

I’m getting a weird behavior using ARFoundation libraries.
I use the same project to build my project for both Android (ARCore / OpenGLES) and iOS (ARKit / Metal) platforms.
Apart from minor lighting differences between the two OS (different lighting scenes), we should expect the same result while using an augmented reality framework.

On Android, it is fine.
But when I turn on AR mode on iOS (and only on iOS), the background is torn and AR objects are following the device movements (like a boat / jelly movement effect).
Here is a video illustrating my issue: ARfoundation iOS Issue - YouTube

I suppose that the real-time video stream being not processed properly causes the tracking being temporally broken… But these should be directly handled by the AR libs, am I right ?

My Application target frame rate is set to 60.
On a 5th gen iPad, we can slow down to 12 fps… but with more powerful devices (> 30fps), we do have the same issue ! So performance doesn’t seem to be the only factor here.

I tried to change update types in TrackedPoseDriver (script attached to AR Camera), but nothing solved my problem.

Has anyone ever encountered this issue, either with ARFoundation libs or with ARKit integration only ?

Thanks in advance.

I’m currently in the process of converting my ARKit v1 app to AR Foundation and I ran into this problem while switching out my code. The issue for me was a null reference exception in my code. I also had made the mistake of upgrading Unity to 2019.1.x. According to the AR foundation Github, AR Foundation currently only works with 2018.3.x

I am using 2019.2.6f1 and ARFoundation. And Even I am having the same issue. I am using Face Tracking feature on iPhone 11. If any one figures out the resolution to this problem, do keep posted. The issue kick’s in after few minutes of using the application. I tried turning of Anti-Aliasing, VSync, Shadow Cascades and almost all settings which I thought could cause the issue. However I noticed its the entire camera screen stuttering.

Same issue on iOS (6th gen iPad) AR Foundation 4.3.2 and Unity 2021.3.

Was hoping to find an answer. Any luck @abennani ?