ARKit XR is not enabled error though it is enabled

Here, an error is rising while I am building a project in MAC for iPad. I am currently using MARS for the project and there is this issue.

Please enable the ‘ARKit’ plugin in ‘XR Plug-in Management’.
Open Project Setting > XR Plug-in Management > iOS tab and enable ARKit.

Although ARKit is enabled, the issue still says I have enabled it!

I have disabled and again enabled it, I have tried to build it on different projects and tried it on two different editors, but it didn’t work at all.

Unity Hub: 3.4.2
Unity Editor: 2020.3.47f1, 2021.3.23f1
AR Foundation and ARKit XR Plug-in: 4.2.7
Unity MARS: 1.5.0
XR Plugin Management: 4.3.3

I’m having exactly the same problem here!


I see that you are using 2020.3 could you please update to 2021.3 and see if the issue reproduces.

If the issue does reproduce please report a bug for it.
Please make sure to write the exact steps needed to be taken so that the reproduction would be visually seen. Also make sure to attach a reproduction project and any visual material so that when testing our CQA team can verify that they got the same results. If you can, please use this template:

How to reproduce:

  1. Open the attached project
  2. Do this
  3. Do that
  4. Select this
  5. Observe that

Expected result: Something is visible, something is printed or something happens
Actual result: The opposite of what I expect happens

Reproducible with: Editor version I am using (e.g: 2021.3.xf1)

Reproduced on: The OS I am on (e.g: Windows 11, macOS Ventura 13.1 (Intel/Silicon))