Artifacts when importing Blender to Unity?

alt text

I always get these strange artifacts when importing from Blender to Unity. I think it might have to do with UV mapping, because this happens with any shader that uses a bumpmap. What should I do?

looks like bad normals. Here's a quick fix:

1:select ONLY your object

2:go into edit-mode

3:select all FACES

4: control+N, recalculate normals.

All should be well then :-)

once you’re totally sure that your normals are sane (just like others mentioned), check your tangets!
either you try to set the Tangents option on your object to “import” (default is calculate), or you try to find out why they are calculated wrong. for example: if you do not have any UVs, or they are weirdly distorted or scaled, Unity will calculate wrong tangets.

some shaders need sane tangents in order to work.