ARtoolkit problem on android

Hi guys, I’m having troubles at running ARtoolkit (one Augmented Reality framework) on android.
Seems like after releasing of unity 5.2 issues related to the shader/material used to the video panel made it impossible to work, but I fixed it after using the following shader instead:

Shader "VideoPlaneNoLight" 
    _Color ("Main Color", Color) = (1,1,1,1)
    _MainTex ("Base (RGB)", 2D) = "white" { }
        Diffuse [_Color]
      Lighting Off
      ZWrite Off
      Blend SrcAlpha OneMinusSrcAlpha
      SeparateSpecular Off
      SetTexture [_MainTex] 
        constantColor [_Color]
        Combine texture * constant, texture * constant

I’ve also had some problems building on android, but after creating the right plugin I’ve finally made it work. Problem is the phone shows no video and only a black screen (even tough the menu works).
I don’t know if it’s a problem related to the camera or the material I used, someone with more experience could help me out?

more detail, and a possible anwser this time. At least a solution that worked for me.

I just ugraded to Unity 5.2.2f1 and the same project that crashed my ARToolKit app now work.

Good luck.

Whenever I build for Android, I get this error, Null reference exception :frowning:
Any help please.

NullReferenceException: Object reference not set to an instance of an object
ARTrackedObjectGizmo.DrawMultiMarker (.ARMarker m, Matrix4x4 mat, Boolean selected) (at Assets/ARToolKit5-Unity/Scripts/Editor/ARTrackedObjectGizmo.cs:117)
ARTrackedObjectGizmo.DrawMarker (.ARTrackedObject to, Boolean selected) (at Assets/ARToolKit5-Unity/Scripts/Editor/ARTrackedObjectGizmo.cs:86)
ARTrackedObjectGizmo.RenderARTrackedObjectGizmo (.ARTrackedObject to, GizmoType gizmoType) (at Assets/ARToolKit5-Unity/Scripts/Editor/ARTrackedObjectGizmo.cs:60)