Assembly cannot be loaded on Cloud Build.

Hi,
I am using Unity 5.4.1f1 (the same version is set on Cloud Build). I have the newest IAP and Facebook SDK version 7.8.0. When I build both iOS and Android on my local computer everything is fine. I even exported it to XCode project to build it on Mac and everything is fine. But I’m not able to successfully build my project on Cloud Build.

The problem I get is:

[Unity] -----CompilerOutput:-stdout--exitcode: 1--compilationhadfailure: True--outfile: Temp/Assembly-CSharp-firstpass.dll
 [Unity] The following assembly referenced from /BUILD_PATH/xxx.default-android/Assets/Plugins/UnityPurchasing/Bin/Stores.dll could not be loaded:
[Unity]      Assembly:   Tizen    (assemblyref_index=7)
[Unity]      Version:    0.0.0.0
[Unity]      Public Key: (none)
[Unity] The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/BUILD_PATH/xxx.default-android/Assets/Plugins/UnityPurchasing/Bin/).
[Unity] Could not load file or assembly 'Tizen, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies.
[Unity] Unhandled Exception: System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
[Unity]   at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
[Unity]   at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
[Unity]   at Mono.CSharp.RootNamespace.ComputeNamespaces (System.Reflection.Assembly assembly, System.Type extensionType) [0x00000] in <filename unknown>:0 
[Unity]   at Mono.CSharp.RootNamespace.ComputeNamespace (Mono.CSharp.CompilerContext ctx, System.Type extensionType) [0x00000] in <filename unknown>:0 
[Unity]   at Mono.CSharp.GlobalRootNamespace.ComputeNamespaces (Mono.CSharp.CompilerContext ctx) [0x00000] in <filename unknown>:0 
[Unity]   at Mono.CSharp.Driver.LoadReferences () [0x00000] in <filename unknown>:0 
[Unity]   at Mono.CSharp.Driver.Compile () [0x00000] in <filename unknown>:0 
[Unity]   at Mono.CSharp.Driver.Main (System.String[] args) [0x00000] in <filename unknown>:0 
[Unity] - Finished compile Library/ScriptAssemblies/Assembly-CSharp-firstpass.dll

I don’t use Tizen anywhere, my guess is that IAP has just reference to Tizen but it’s missing. Does anyone have any idea how can I solve that?

this has been happening to me too on all platforms