Assertion failed: Assertion failed on expression: '!GetMainEditorWindow()'

Hi,

I recently updated my unity so I had the same version that I’m using at school (2017.3.0f3) and as soon as I loaded it up I received the following error:

Assertion failed: Assertion failed on expression: ‘!GetMainEditorWindow()’

Essentially it doesn’t recognise any key strokes outside or numbers. I’ve googled the error and it seems no one has ever come across the issue. Please help!

Kind Regards,
George

Hi,
Today I had the same problem! Just started my project and I saw an error. I couldn’t find any useful information on the Internet so I tried to open my project not by clicking on an Unity scene file but by opening Unity with a shortcut from my desktop. There I saw that for some reason my Unity profile was signed out and I needed to log in. After that I had to fill a short questionnaire (reasons why I use Unity and etc.) and my project worked perfectly fine (some sort of bug I believe or magic :smiley: ). Sorry for my poor English. I hope this text was helpful.
Aidas

I also had got that problem and the suggested solution works for me. It was just only a license problem. I started Unity from desktop launcher and it request me for my credentials.

If you fill out the survey you often get, the problem will be solved!
Otherwise, you’ll have to open Unity manually by heading to your Unity installation folder and open the .exe file.