Assertion failed error when creating NetworkDriver or NetworkEndPoint

Hi, when using Unity Transport 0.8.0-preview.8, assertion failed error is shown when creating NetworkDriver.

Log

[spoiler]

Assertion failed
UnityEngine.Debug:Assert (bool)
Unity.Networking.Transport.NetworkEndPoint:CreateAddress (uint16,Unity.Networking.Transport.NetworkEndPoint/AddressType,Unity.Networking.Transport.NetworkFamily) (at Library/PackageCache/com.unity.transport@0.8.0-preview.8/Runtime/NetworkEndPoint.cs:249)
Unity.Networking.Transport.NetworkEndPoint:get_AnyIpv4 () (at Library/PackageCache/com.unity.transport@0.8.0-preview.8/Runtime/NetworkEndPoint.cs:113)
Unity.Networking.Transport.BaselibNetworkInterface:Initialize (Unity.Networking.Transport.INetworkParameter[ ]) (at Library/PackageCache/com.unity.transport@0.8.0-preview.8/Runtime/BaselibNetworkInterface.cs:211)
Unity.Networking.Transport.NetworkDriver:.ctor (Unity.Networking.Transport.INetworkInterface,Unity.Networking.Transport.INetworkParameter[ ]) (at Library/PackageCache/com.unity.transport@0.8.0-preview.8/Runtime/NetworkDriver.cs:524)
Unity.Networking.Transport.NetworkDriver:Create (Unity.Networking.Transport.INetworkParameter[ ]) (at Library/PackageCache/com.unity.transport@0.8.0-preview.8/Runtime/NetworkDriver.cs:491)

[/spoiler]

It does not occurred when using 0.6.0-preview.7.

Edit:
Reported as Case 1338602.

https://issuetracker.unity3d.com/issues/unity-transport-assertion-failed-error-is-shown-when-creating-networkdriver-or-accessing-networkendpoint-dot-anyxx-property

Does anyone look into this issue?

also waiting, any indication when we can get this?

Yes this has been fixed in the next release of the package!

1 Like