Assertion failed on expression: 'channel.frameCount != 0' ,Assertion failed on expression: 'channel.frameCount != 0' - 2018.3.3f1

I’m getting the following error after importing my model into the scene:

Assertion failed on expression:
‘channel.frameCount != 0’

It looks like it has something to do with the animations, I’m not sure what’s causing it. I did try updating to 2018.4 to no avail. Any ideas?

Any answers to this? I’m getting the same error after upgrading to 2018.6 from 2017.4

I get this when messing around with Blendshapes. Scrolling the mousewheel while the mouse cursor is over the inspector while a GameObject with a MeshRenderer is selected in the Hierarchy generates new instances of the error in the Console. I’m on Unity 2018.3.14.

I ran into this issue as well, narrowing it down to a specific character’s blend shapes. The error would spam my console whenever the blend shapes were modified, and sometimes the whole editor or OS would crash!

I was able to resolve it - select the problematic mesh renderer and set the inspector to debug view. There will probably be more entries for blend shapes than necessary. Correct that, and the issue should be resolved!

Thank you for your answer, the exact same thing happened to me. And as you said, for whatever reason Unity has inserted blendshapes into the list that are not there. correct the list item count and all is fine.

This is really weird and probabley a bug.
I got that when converting an asset for a test to HDRP pipeline. The asset was perfectly functional before.

Thanks for all the answers above, I think I solved that. In Unity, by choosing the problemetic Skinned Mesh Renderer (in my case it’s in M3DFemale_LOD0) and setting the inspector into debug mode then changing Blend Shape Weights Size from 6 to 3, the assertion failed error in console can be fixed.

Further info:

This happens when swapping meshes on a skinned mesh renderer. Here are the steps to reproduce:

At edit time or runtime:

-Assign a mesh that has at least 2 blend shapes on a skinned mesh

-Play with the blend shape weights

-Assign a mesh that has less blend shapes than the first on the skinned
mesh renderer

-Notice that the blend shape weight count is greater than the blend shape

It happens when swapping meshes at runtime too, which is a bummer, since I haven’t found a workaround. I submitted a ticket. Hopefully, it will be fixed soon. I’ll keep you posted.