Assertion failed on expression 'GetPathNameExtension(path) == "unity"'

Has anyone come across the error message shown in the title?

It’s started cropping up in the console when our project is loaded. No other information at all (in the console or editor log).

Is the .unity extension ever used for anything other than scene files? I can’t find anything purporting to be scene file that doesn’t have that extension and I’m stumped for ideas.

As far as I can tell, everything is working fine. At some point I’ll try deleting the Library folder and letting it reimport everything to see if that makes it go away, but I’ve too much to do at the moment to take time out for that. I’ll update when I have tried that but in the meantime was wondering if anyone on here had any insights.

[Edit] Have now tried deleting the Library folder to force a reimport, and also imported the project afresh into new workspaces. It doesn’t help.

If there is an error with Unity that you don’t know what caused it. Usually removing Library directory (while having Unity closed), it fixed itself.
Keep in mind, when you remove Library directory, it will cause EVERYTHING in your project to be re imported. And it takes time