Asset Bundle not compatible between different unity versions

Hi, I am making an Asset Bundle in unity 5.2.3f1 (32 bit OS of window) and i want to use it in unity 5.0.0p2 (64 bit OS of window). When i download asset bundle from unity 5.0.0p2 my editor has crashed. Is there is compatibility problem ?

I have just encountered this issue as well with asset bundle created in 5.6.2 crashing an app made in 5.6.0.

Trying to figure out if there is a way we can handle this.