Asset "John Lemon" is all black despite material import and light source.

I’m following the John Lemon Haunted Jaunt tutorial and after importing the assets as the guide instructed and moving John Lemon into the scene, he was entirely black. There’s a directional light there already, so I’m not sure why this is. I thought maybe the tutorial would show me how to apply materials but it got to a point where it was showing screenshots of what I should have and John Lemon is textured and visible for all to see. Even the “albedo map” is completely black in the inspector, but not in the asset window. As mentioned there’s already a directional light in the scene, moving the light and the model around doesn’t seem to yield any differences in the model’s appearance.

I’m using Unity 2019.1 on Linux on a bit of a toaster with an iGPU so…that might be it. But if anybody can give me something else to look at, I’d appreciate it. Cheers.

EDIT:

I’m not entirely sure the revision of the title was helpful. Seems more like a bug than user error. The materials are there, I can see them. I don’t need to know how to import materials, I need to know why the model is appearing black even after the materials have been imported. I’ve added a screenshot of my window so there’s less confusion about what I’m asking about. Thank you.

![alt text][1]

[1]: http://i.imgur.com/7EAr9tY.png+++![](http://imgur.com/7EAr9tYl.png
)

I played around with it some more and unchecking the “sRGB (Color Texture)” checkbox allows the texture to be seen correctly. To be clear I’ve never touched this before, so it must have been imported this way.

Can someone explain why this is? This seems to be incorrect behaviour but I don’t know.