Asset Pipeline V2 annoying error all the time

Hi,

Just for the record: with our without cache server the error is the same. I just didn't know where to post this as it's clearly related to the new Asset Pipeline V2 and there are no clear sub-forum for that.

Context: I have a big project, all migrated to 2019.3.3, I needed to install Entities and weirdly enough at the end of that installation I got a message in console stating that I needed the Asset Pipeline V2 to use it. Fair enough, let's go for actually 6 hours of upgrade to this pipeline V2.

Once it's finished, my project seem to work fine overall. But... I have this error absolutely all the time. It's really annoying as there are no log trace, no explanation on what this is and of course if I google the error I find all the "Assertion failed on expression" error possible except that one:

Assertion failed on expression: 'gOnDemandAssets->empty() || GetOnDemandModeV2() != AssetDatabase::OnDemandMode::Off'

Clearly this is related to the new pipeline but I have no idea how to fix this.

It pops:

-When saving the scene
-When entering play mode
-When exiting play mode
-When compiling a script
-When creating a folder in the project view

I didn't try but I think if I sneeze that will also pop the error.

While it seems harmless, it makes readability of the console horrible and as anyone here, I just don't want errors that I can't do anything about if I don't have a proper log behind.

Can anyone help me please? And I have no idea on how to reproduce it seriously.. I can't pack my project as it's way too big. It just happened after migrating from pipeline v1 to v2... that's all I know

Thank you by advance.

That is interesting... hard to find the issue without being able to reproduce it. But I will look at the code and see if there is anything that could make this happen.

It’s bothering me to not be able to have a more detailed log so I can also help to pin point what is causing the issue to be honest. I work in IT, troubleshooting is a core part of my life. But here I’m clueless and it’s super frustrating. Is there no way to enable some “deeper” log or tracing? I mean I can just press “Save scene” to trigger the error that’s super easy.

The spam of errors is quite insane as it is popping all the time.
I noticed that if I recompile one of my own script, the error will come with a stack trace related to my script. It’s false errors, the code has no issue

Don’ t know if it’s a hint but I know I have some prefabs in my project with missing scripts, I do not know if the pipeline migration on top of that is making them being a bigger issue. I don’t know exactly which objects are like that, and if it matters at all. I know that I have none of those prefabs in my scenes.

As I said, the project seem to work fine, all my systems are up and running etc.

Any chance for some new @jdrewsen ? or hints to help me help you find out what is creating this issue? The console spam is really extremely annoying for an error that doesn't seem to create real issues

On a copy of the project, try deleting the library folder to see if it makes a difference. Likely something somewhere has a reference that’s dead to the assets from before, Unity’s side.

Hi, as I thought migrating from V1 to V2 was doing the same as a Library delete (I read that on the Unity blog I think) I didn’t try.
But just for removing any doubts, I did that, and after 4 hours of building the library, same result, no difference at all…

5551246--571633--upload_2020-3-4_19-45-6.png

I really just wished there was a way to troubleshot what assets have broken reference. Is there not any way for me to find out? (considering the project is quite big)

1 Like

I've posted some additional information that might be useful in this thread: https://discussions.unity.com/t/777955/2

If anyone can give me a copy of their failing project (incl. Library folder etc).. I could try to repro here and figure out what is wrong.

2019.3.2f same error... i can't find what is wrong.. every time i play the enter playmode and compile script errors occur

Please checkout my comment here https://discussions.unity.com/t/777955/2