Asset Server Compare no longer works

After updating to Mac version v3.5.2f2 my Asset Server diff/compare tool no longer runs.

Repro steps are as simple as selecting a file in Local Changes and then clicking Compare; a message box pops up saying ‘initialising compare’ then nothing occurs.

My diff tool of choice is Apple File Merge which works a treat outside of Unity.

Any help on tracking down the issue would be much appreciated - the turn it of/turn it on again approach sadly didn’t work… :confused:

I had the same issue on Mac. I installed SourceGear DiffMerge and changed the setting in Preferences->External tools. Compare is finally working again.

Mac 10.7.4
Unity 3.5.2f2
Xcode 4.3.2

I ran into this same issue, it is likely a problem with XCode, not Unity. Try reinstalling xcode, then reboot unity. I was too lazy to go through that myself so I just installed another diff tool:

From the Unity Docs:

On Windows:
    TortoiseMerge: part of TortoiseSVN or a separate download from the project site.
    WinMerge.
    SourceGear Diff/Merge.
    Perforce Merge (p4merge): part of Perforce's visual client suite (P4V).
    TkDiff. 
On Mac OS X:
    SourceGear Diff/Merge.
    FileMerge: part of Apple's XCode development tools.
    TkDiff.
    Perforce Merge (p4merge): part of Perforce's visual client suite (P4V).

Just ran into the same issue. The “Initiating compare” dialog popped up but then nothing happened.

I was able to open FileMerge manually but in the Console the following message turned up:

Agreeing to the Xcode/iOS license requires admin privileges, please re-run as root via sudo.

Turns out I installed a new version of Xcode and hadn’t opened it yet to agree to the new license terms. Somehow FileMerge still worked but I suspect the opendiff command line utility that Unity probably uses to open FileMerge did not.

After changing the value in Command Line Tools to XCode 5.0.2
in XCode->Preferences…->Locations Compare is working for me.