Asset server emptying whole scene while Merge or Discard changes!

Hello everyone!

It seems the Asset server dissapointing here!

We are two people only working on a project, I am new to the asset server but I have been used Microsoft’s SourceSafe for a while.

The problem we had is while a conflict, the other employee had chose “merge” and the whole scene data had been gone(scene is totally empty, no even main camera).

Tried to get from history, neither option did bring the scene back…
Great that I did not rely on the asset server and had a backup on my USB.
We reopened the project , connected to the asset server, after pc-2 made some changes and committed , when updating from my pc again the conflict resolution box opened , and this time he did click on the “Discard my changes”, same thing happens, the scene is empty again.

Is it an issue happening with others?? what might be happening?


Same happened to me. 2 hours of hard work just gone ((

We had the same issue. Changing the project settings to Force Text (Edit / Project Settings / Editor / Asset Serialization Mode) fixed it for us.

Hey! I’m not sure if this will help you in this case, but if you can get both files into your project at the same time, you can use our tool to merge the scenes!