Asset Server error when trying to start

I’m running a new install of Asset Server 2.0.1 on a Windows Server 2012R2 VM in Azure. I had everything up and running, and it worked for a few hours. After that I could no longer connect from Unity.

So I logged on to the server, and the service was no longer running. I tried to restart it, and it failed to restart. The error log said:

FATAL: could not reattach to shared memory (key=228, addr=016E0000): 487
LOG: startup process (PID 1680) exited with exit code 1
LOG: aborting startup due to startup process failure

I googled this and found some posts saying this is related to a known bug in the version of PostgreSQL that Asset Server uses, but apparently Unity uses a modified version, so I’m guessing I can’t just upgrade it to a newer version.

Does anyone know any workarounds for this? Would an older version of Windows Server be more compatible?

Here is what I have tried (unsuccessfully):

-Re-installed Asset Server several times, with and without keeping existing projects, etc.

-Running Asset Server installer as an admin.

-Running Asset Server Control as an admin.

-Restarting the VM itself (this fixed it the first time but hasn’t helped since)

-Disabling anti-malware, re-installing and testing still with anti-malware off

-Verified that unitysrv user did not require password reset on next login

-Verified that unitysrv had full control permissions on Unity folder and all subfolders

-Set asset server service to run as local user instead of unitysrv user

Any help would be greatly appreciated.

Maybe you need to reset or recover your windows password and I tried Password Manager For Windows to recover mine and it worked very well and give my windows stronger protection.Hope to give you some help