Asset Store Connection timed out with proxy

hey guys,

Im using Unity 5.3 in Windows 10.

Im having the following problem:

I cant download any asset from the Asset store.
I can login, connect to the Asset store and even buy assets.
when i try to download any asset i get " Error: Connection timed out" .

Yes im behind proxy, but when i set the env variables (HTTP_proxy ) i cant even login eventhough im sure is the correct one ( i use it for git and it works )

i found a solution for this problem. if somebody else has it just copy and paste the env variable as HTTPS_proxy too and reload unity.


Tried & tested 2 solutions to this:

  1. R-Click: MyComputer → Properties → Advanced System Settings → Advanced(Tab) → Envrionment Variables
  1. Create a batch file: (Very good especially if you have no admin rights)
    set HTTP_PROXY=
    set HTTPS_PROXY=
    start D:\MyInstallPath\Editor\Unity.exe

Well, I dont know if you still want to know but I fix it by allowing Unity in the windows firewall. If you dont know how to do it you can follow the method 1 in this guide :slight_smile: