Asset Store Is Just A Grey Screen

So I just downloaded Unity 4.5 and I wanted to use one of the tutorials to learn Unity, so I tried downloading tutorial assets from the Asset Store, however when this occurs the Asset Store in Unity just loads up with a blank grey screen and stays that way forever. The same thing happens when I open up the Asset Store within Unity. However I’m pretty sure the Asset Store has loaded because my cursor changes when I move my mouse around the screen.

I’ve tried the following and none of them have worked:
Uninstalled and reinstalled Unity.
Logged in and out and back in again on the Asset Store.
Used a different web browser to open Asset Store.
Restarted my computer.
Disabled my firewall.
Tried to download another asset from the store.
Waited thirty minutes to make sure that it’s never going to load.

If anyone can provide a solution that would be great as this is driving me crazy.

goto edit > project settings > player, untick ‘use direct3d 11’

So I managed to solve it and in case anyone in the future finds this, this is how I fixed it. I logged into this link. as opposed to Unity Asset Store - The Best Assets for Game Making, how this worked I have no idea as it’s completely nonsensical, but there is my solution to the problem.