Asset Store not downloading

Hi there, I recently installed Unity again onto my computer and I’ve tried both through the browser (loading a particular asset in the Unity application), and through the application itself. The asset is free, and when I go to download it, it comes up with a random percentage (47% for example), and then suddenly drops to 9% or something. And from there the download does not progress whatsoever. I’ve tried logging in and out of both in Unity and in my browser, I’ve restarted the application several times and nothing has changed at all. I have no idea why the download won’t work, I really would appreciate if someone could help shed some light on the situation as I really want to get this asset so I can start working in Unity.

Mine had download issues because my internet connection is shady at best… to fix partial downloads:

If your downloads have started and gotten to ##% done, but are stuck there, then do this:

  1. Close Unity program.

  2. Find your download location:

    Windows 7, 8 : C:\Users\UserName\AppData\Roaming\Unity\Asset Store
    Windows XP : C:\Documents and Settings\UserName\Application Data\Unity\Asset Store
    OSX : ~/Library/Unity/Asset\ Store/

  3. Inside your download location you will see folders with the names of the user/group/etc who created them. Inside there you will find .tmp and .json files. Simply delete them all.

  4. Reopen Unity.

  5. If you want to try downloading again then open the Asset Store window and then open your download manager. Download Manager should be a small button at the top of the Asset Store window that looks like a box with an arrow pointing down into it… should be the 5th button over based on my window I’m looking at right now. ‘Download’ button should be available now to try again.