Asset store not playing YouTube videos

This has just started happening. I’m running Unity 2018.2.8f1 and the latest Win10 build with the latest Firefox as the browser. When I try to view the asset store promo videos I just get an error message “Your browser does not currently recognize any of the video formats available”. It was working fine yesterday and I don’t think there has been any significant changes since that I know of. I tried using my old computer (64 bit Win7) where I still have Unity 2017 installed and got the same result - so not OS presumably. I also tried using Microsoft Edge as my default browser but got the same error - so not browser? I’m just left with a possible problem with the Unity Asset Store setup. Any one have any ideas that might help me?

Having the same problem, all the browsers seem to playback youtube just fine. shows all supported.

Unity asset store give the
Your browser does not currently recognize any of the video formats available.
Click here to visit our frequently asked questions about HTML5 video.

I get the same error, no way to fix it?

I used to be able to watch the videos a month ago or so. Now I can’t at all.

I apologize to the Unity community for using the Answer box instead of commenting, but it seems like the most obvious way to get things noticed.
UPDATE: Things have got much much worse. I can’t even look at the promo videos on my browser outside of the Asset Store now. A message appears telling me I can’t use the Asset Store because I’m offline - which I am most definitely not. Also, the same thing is now happening when I try the Asset Store from within the Editor. I am then locked out of the Asset Store until I restart Unity to get back to the Asset Store. I click the Asset Store tab and I can browse the assets as normal but as soon as I click on a YouTube promo video the message tells me I’m offline. What the hell is happening here? No way am I going to risk buying any assets while the system is this stuffed up. Oh, BTW, I tried to login to my account via the Unity web page and it asked me to allow this Zendesk ap (which I’ve not heard of before) to link to my account. I don’t think so. A quick look on the internet for Zendesk is not reassuring. Come on Unity, please sort this out. I’ve got assets to buy.

Now I can’t load all asset store information in firefox either. descriptions, other items just spin spin spin the loading icon. I can only view asset store items in explorer. Pretty great timing with the sale going on at the moment. Is anyone working on this?

Also experiencing from Unity editor Asset store: “Your browser does not currently recognize any of the video formats available.”
Unity 2018.3.0f2 macOS Mojave

Please fix this, Unity team!

still broken.

Yeap broken!

Still broken

I have the same issue here 2018.4.20f1. Any way to fix it?

Still broken

This is unacceptable if you are not going to make external videos on youtube work you should host them there at unity. This is such a pain and breaks development flow when you are looking for an asset real quick to fill a need you have to open another app for something your app should do anyways.

Its these random quirks that really get on my nerves with unity