Assets > Create > Tile missing

I’m very confused. I’m new to Unity, and I’m following the Ruby RPG tutorial, but I ran into a problem. I can’t continue the tutorial, because there’s no option to create a tile! Everything I’ve looked up says that it’s there under Assets > Create, but I just can’t get it to show up. I tried restarting Unity and re-importing all, but nothing gets the option to show up. What’s going wrong, and how can I get the option to show up in the context menu?

Note: In recent versions of Unity (I’m working with 2002.2.0a18 right now) they seem to have removed the “Asset - Create - Tile” feature for creating single tile assets. The 2d Tilemap Editor gets installed as default for new 2d projects, but the current workflow is to drag sprites or spritesheets into the tile palette editor (Windows - 2D - Tile Palette) , which then automatically creates the tile assets for you. And the documentation was not yet updated, it still mentions that you can manually create single tiles in the “Assets-Create” context menu. Which is pretty confusing.

In 2020.3 the best option to follow the Ruby tutorial seems to be to

Create a Tile Palette (Create - 2D - Tile Palette - Rectangular) in Assets/Art/Tiles.

Import the tile sprite by dragging it into Art/Tiles.

Now open the new Tile Palette by clicking “Open Tile Palette”-

Finally drag the tile from the Project Window to the new Palette:

Now you can continue following the tutorial.

The ‘2D Tilemap Editor’ package must be installed via the Package Manager in order to have this as an option.

The accepted answer here is now WRONG. There is currently no way to do this unfortunately so far as I can tell, even with the package installed. Not sure what the folks at Unity were smoking EVER removing such a fundamental feature out of core.

Hey guys, I had the same issue today (Ruby’s Adventure tutorial). mtoman’s reply is good. The official documentation for 2020.1 has more detail. Here’s the link:

Basically, here are the steps from the very start (maybe go straight to step 5):

  1. Window > Package Manager > 2D Tilemap Editor > Install
  2. GameObject > 2D Object > Tilemap > Rectangular
  3. Download Tile.png
  4. Import New Asset (or drag?) file into folder Assets/Art/Tiles under Project window
  5. Window > 2D > Tile Palette (window opens)
  6. Create New Palette > Name it GamePalette
  7. Drag the imported Tile.png file (has an arrow icon on it, Texture 2D file type) into GamePalette’s window
  8. Tile asset automatically generates there and within Project window (no arrow icon, Tile file type)

So due to this auto-gen feature, the sequence of steps in the tutorial seem mixed up and rather outdated. Frustrating that they haven’t updated it for over two years. Anyway, hope this helps someone in the near future. :slight_smile:

This drove me bonkers too, and some of the previous responses helped me out.

Basically, skip this step and go down to step #5. Creating the tile palette first makes this a lot easier.

1.) Do Step 5, follow instructions to create a new Tile Palette
2.) THEN - import the tile.png asset into your Art/Sprites folder. If the imported asset has a texture type of “default” - change it to “Sprite”.
3.) Now drag your new sprite onto the newly created tile palette - this will automatically create the tile for you. Save the tile in your tile folder and continue with the tutorial.

PS: As stated by other posted, with newer versions of Unity you do not need to install the 2D Tilemap Editor package. It should already be install for you when you set this up as a 2D project.


For those that are using Unity versions that no longer have the Create/Tile option. You can pretty easily replace the option with your own by creating an editor script like this one (make sure you place it in a file inside an Editor folder):

using UnityEditor;
using UnityEngine;
using UnityEngine.Tilemaps;

public static class CreateMenuItems
    private static void CreateTile()
        var tile = ScriptableObject.CreateInstance<Tile>();
        ProjectWindowUtil.CreateAsset(tile, "Tile.asset"); 

Can confirm 2020.3+ does not have single tile in Create menu.
I wanted to create dynamic tiles in runtime but don’t know how right now. Might try image.

Window>Package Manager
There will be the 2d Tilemap Editor option, just install on the > screen button