Assets Folder Appearing to be Empty

I first started doing the Unity tutorials back in mid-July, and after taking a break, I’m back trying to complete the ‘Survival Shooter’ tutorial. When I first logged in to Unity, I was prompted to upgrade to version 5.2.2, and I did. After updating and logging in, I was told that my ‘machine identification is invalid for current license’. I was then prompted to enter my log-in details again and select Unity personal edition. Every time I open Unity, it forces me to log-in twice and re-select Unity personal edition. I think this might have something to do with the problem I’m experiencing;

After getting into Unity and creating a new project, I imported the package for the tutorial and got to about halfway through the second video, when I was told to open a script. I did this, but instead of opening on Monodevelop, the script tried to open on Visual Studio (something I didn’t even know I had), and stalled at the halfway point in the loading bar. Monodevelop then opened a new tab, but it too had a loading bar that stalled in the middle. I decided to try closing the editor and changing the external preferences, as was suggesting online. Before doing this, I saved the scene (and had been saving the scene every step of the way) into the scenes folder in the assets folder of the Survival Shooter project. When I tried to re-open it, I found that Survival Shooter’s assets folder was completely empty. I then tried directly searching for my .unity file and was told that ‘Windows in searching for’ my file. I then thought I must have made a mistake in saving my files, so I redid the tutorial to the point I left off at, but forgot to adjust the external preferences, causing Visual Studio and Monodevelop to both stall at the halfway point.

I’ve been trying to save my file, but nothing’s working. In the ‘save as’ menu, it shows that the Assets folder has folders and scenes in it, but when I open another unity tab, the assets folder is empty. I’ve tried opening previous tutorial projects and they all have their assets and scenes folders intact.

Is there anything that could be causing the assets folder to be empty?

Update: have tried creating new project and saving to old project, the saved scenes still aren’t appearing. Unity froze when I tried to make a project with the destination of a USB.

Having this trouble too. For 5.5.1