Assets Server connection refused

I had the asset server up and running fine for quite some time now but I suddenly stopped working.

It gives the error message:

Failed to connect to asset server: could not connect to server: Connection refused (0x0000274D/10061)
Is the server running on host “” and accepting
TCP/IP connections on port 10733?

when i open up the asset server panel within unity.

If I ssh to the host, this is what i found:

  1. the server is online since i can connect to it
  2. the asset files are there. (in the asset directory)
  3. the asset server system files are there (in the /opt/unity_asset_server/) directory
  4. If i try to run the command to reset the asset server admin password (sudo /opt/unity_asset_server/reset_admin_password)

I get the following error:

psql: could not connect to server: No such file or directory
Is the server running locally and accepting
connections on Unix domain socket “/tmp/.s.PGSQL.10733”?

  1. If I run “top” to figure out whats running on the box I get the following list of services:


Any ideas on what why the server suddenly stopped working? It looks like it is not currently running. Is there a command to restart the asset server service? Is it safe to re-install the asset server with the assets sitting there? I already tried rebooting the linux box(hosted through dreamhost) and I backed up the asset directory, but i have been unable to backup the asset database using the as_backup command…

I got the same message when calling as_backup. Reinstalling didn’t work (rpm had issues?), so i removed the socket files from /tmp/ (/tmp/.s.PGSQL.10733 and /tmp/.s.PGSQL.10733.lock). After a reboot the backup worked like a charm.

I get the error too,and I don’t know how you do it.But I download the asset server form “”.Finally,I start the server and connect it.And the error never happend again.

Okay Breath ! Just un-install to unity server restart your computer… then again install the unity server… go to firewell setting —> tick both private and public also double click on that and check that you port is set to 10733 is yes then ok… Breath . ! . . NOw ! just run the server and access it through unity Hope it will work …