Assets won't Import

It isn’t even showing me an error message. I download the asset, it looks like its downloading. The option to import appears, but when I click on it, I hear a little “ding” error jingle that my computer makes when I tried to do something it refuses to do. I’m not sure what the issue is, but I have yet to successfully import any assets.

Directly from the store. Through unity, I open the asset store, or I am on Unity’s page, then it opens Unity for me and the store to be “imported”

I tried closing Unity and re-opening as Admin (I am on windows 8) and it allowed me to import then, but the next time (about 30 minutes later, same instance of Unity open and running) it did the same thing. Seems like re-starting the whole program fixes it, so I’m not without a way to do it, but it’s a little annoying to have to keep restarting Unity each time I want to import an asset.

I would still like a more permanent fix, if anyone has any ideas

Hi, this happened to me recently.
Just be sure to stop the game before trying to import any asset from the store.

Hope you can solve this.

I had the same problem on Windows8, I could import a package only from menu bar /Assets/ImportPackage/Custom and choosing from explorer maybe it works for you too.

4 years later, same issue on Windows 8.1… seriously ?!!