Astar Internet problem

Whenever i try to run the game in my editor it doesnt work and send me these error messages:

Non-secure network connections disabled in Player Settings
UnityEngine.Networking.UnityWebRequest:SendWebRequest ()
Pathfinding.AstarUpdateChecker:DownloadVersionInfo () (at Assets/AstarPathfindingProject/Editor/AstarUpdateChecker.cs:224)
Pathfinding.AstarUpdateChecker:CheckForUpdates () (at Assets/AstarPathfindingProject/Editor/AstarUpdateChecker.cs:185)
Pathfinding.AstarUpdateChecker:UpdateCheckLoop () (at Assets/AstarPathfindingProject/Editor/AstarUpdateChecker.cs:151)
UnityEditor.EditorApplication:Internal_CallUpdateFunctions ().
InvalidOperationException: Insecure connection not allowed
UnityEngine.Networking.UnityWebRequest.SendWebRequest () (at <f4953a2b498b49e686c06a48e7c10c85>:0)
Pathfinding.AstarUpdateChecker.DownloadVersionInfo () (at Assets/AstarPathfindingProject/Editor/AstarUpdateChecker.cs:224)
Pathfinding.AstarUpdateChecker.CheckForUpdates () (at Assets/AstarPathfindingProject/Editor/AstarUpdateChecker.cs:185)
Pathfinding.AstarUpdateChecker.UpdateCheckLoop () (at Assets/AstarPathfindingProject/Editor/AstarUpdateChecker.cs:151)
UnityEditor.EditorApplication.Internal_CallUpdateFunctions () (at <da771086bc2e4cfc9ad0a72e083a7f98>:0).

There was an error checking for updates to the A* Pathfinding Project
The error might disappear if you switch build target from Webplayer to Standalone because of the webplayer security emulation

Error: Insecure connection not allowed
UnityEngine.Debug:LogWarning (object)
Pathfinding.AstarUpdateChecker:CheckForUpdates () (at Assets/AstarPathfindingProject/Editor/AstarUpdateChecker.cs:164)
Pathfinding.AstarUpdateChecker:UpdateCheckLoop () (at Assets/AstarPathfindingProject/Editor/AstarUpdateChecker.cs:151)
UnityEditor.EditorApplication:Internal_CallUpdateFunctions ()

I have turned on unsafe mode, my build is windows mac linux and dedicated server, which i dont have the dedicated server support for. My internet is fine and i tried going back to see if i could go back to where it worked but it didnt change even though i changed it back further back then where i was when this error happend. Ive also tried turning off windows firewall. Note that it works if i run and build on my pc.

Would you kindly please report this issue via the Bug Reporter tool?
https://unity.com/releases/editor/qa/bug-reporting
Please make sure to write the exact steps needed to be taken so that the reproduction would be visually seen. Also make sure to attach a reproduction project and any visual material so that when testing our CQA team can verify that they got the same results. If you can, please use this template:

How to reproduce:

  1. Open the attached project
  2. Do this
  3. Do that
  4. Select this
  5. Observe that

Expected result: Something is visible, something is printed or something happens
Actual result: The opposite of what I expect happens

Reproducible with: Editor version I am using (e.g: 2021.3.xf1)

Reproduced on: The OS I am on (e.g: Windows 11, macOS Ventura 13.1 (Intel/Silicon))

Well, I’m pretty sure the issue is on the arongranberg side. It seems their update script uses “http” URLs like
http://www.arongranberg.com/astar/version.php

which when entered in a browser is actually redirected to https. However the http connection is nowadays considered “unsafe”. Unfortunately, when you actually watch at the data returned by their version.php, the other URLs in that data are also http URLs. So they should probably change / update their URLs to use secure connections.

version.php results
3.8.12|
No summary available for this version. Take a look at the changelog for more information.|
http://www.arongranberg.com/astar|
7|

URL:download|
http://www.arongranberg.com/astar/download|

URL:documentation|
http://www.arongranberg.com/astar/docs/|

URL:changelog|
http://www.arongranberg.com/astar/documentation/3_8_12_c27a7b0e/changelog.php|

URL:astarpro|
http://www.arongranberg.com/astar/buy|

URL:findoutmore|
http://www.arongranberg.com/astar|

URL:download|
http://www.arongranberg.com/astar/download|

URL:homepage|
http://www.arongranberg.com/astar|

VERSION:branch|
3.8.12|

VERSION:beta|
4.3.77|

URL:beta_changelog|
http://www.arongranberg.com/astar/documentation/dev_4_3_77_a0bb1cd91/changelog.php|

I’ve splitted the text at the “|” symbols so it’s easier to read. As you can see all URLs reported are also http links.

According to the change log the latest version already has a fix for that.

Fixed not being able to check for updates in Unity 2022.1+ because https must now be used for all web requests.

So you may need to manually update the package once and it might fix the problem. If not, you might want to contact them to get support for their product, especially when you use the paid version.