Audio Clipping Problem

I have a small puzzle game, where you merging squares together. There is just music in the background and some sounds when you play (moving, merging, teleport, etc.).

But I have a problem with clipping audio. I attached also an audio example. Clipping starts at 10s.

[138992-clipping-audio.zip|138992]

Of course, I have checked possible solutions here on the forum, but no one works. What I have tried so far is:

  1. I turned off Doppler Level on the audio source and also in project preferences

  2. I turned down the volume on the audio source and also in project preferences, so when sounds and music is layering, clipping should not occur.

  3. I have checked audio files and no one is clipping itself.

Do any of you have an idea how to solve this? Thank you very much for any help.

Have you tried going into your project’s audio settings and changing the DSP sample rate in project settings to best performance?