Avatar mask affects on unselected bones

Hello there!
Have some issue with avatar mask

I have a Generic animation, with this mask:

And I have an Avatar mask:

“Arms_Parent” is unchecked everywhere, because I dont want animate this bone.
So I made only one layer in animator, which assigned to this Generic animation. And I assigned Avatar mask to this layer with unselected “Arms_Parent”.
But “Arms_Parent” still animates

Where could be problem? How can I disable animation for “Arms_Parent”?

Sorry for my English

Had a similar issue, so just posting an answer for those coming across it in the future.

The problem (in my case and probably OP as well) is that the Arms_Parent Bone is a child of other bones (Player_Root > Bones > Body_Rotate > Body) which are enabled in the Avatar Mask. Meaning that anything that affects any of the Parent bones automatically affects Arms_Parent even if it’s disabled in the Avatar Mask.

It’s rather stupid / unexpected behavior, since you’d expect any bone that’s not selected in the Avatar Mask to be ignored in the animations, but unfortunately it doesn’t work that way.

The only solutions I could think of:

1) Uncheck any parent bones (Player_Root > Bones > Body_Rotate > Body), though that might not be always an option depending on which ones are required for your animation... 

2) Have another animation override the Arms_Parent animation. Could be as simple as a single keyframe animation, where the Arms_Parent is just keyed to the position you need it in. Or alternatively just do it as part of another animation, rather than creating a whole new one. You might not even need to create an animation, if the Arms_Parent bone is in the position you need it to as part of another animation. 

Also - the order of the Layers in the Animator seems to be important as any of the layers at the top get overrided by those below it… at least if I recall correctly.