AvatarMask not avaliable for Animation Layers...


When I look at the relevant documentation:
I cannot get to the settings shown on the second&third pic, where there are two types of "Masks" : "Humans" "Bones" available in the newly added Animation Layer.
I only get one single "Mask" as in the first pic...
The selection window for this "Mask" remains empty, even though I already created my own "ArmsOnlyMask", so I can't get my mask to be used in the new animation layer. I tried to mark this in the pic attached....

This is the step described at 44:27 in this tutorial video:
The surface simply never looks like this for me when I add the second animation layer...

What am I missing here?:face_with_spiral_eyes:


Make sure you've upgraded to the latest Unity (4.2.2), and try recreating the Avatar Mask. The documentation is outdated. Unity combined both mask types into a single Avatar Mask.

Thx for your answer.

I am in the latest version and I just recreated the mask, the rig, the animation controller, the whole scene, the project....

The result is the same, I can't get the mask into the Layer, neither via selection window (which remains empty as seen in my pic) nor via drag 'n drop.

No idea what's going on, I'd really need masks further along our project.
Can't imagine this is a bug, since somebody else would have come across that by now I guess.

Sorry, I have no idea either. Perhaps submit a bug report. If you find out the answer, please post it here.


The problem was that no selection window worked at all and getting the mask into the layer was the one thing not doable via drag 'n drop...
Blessedly this has been solved by updating to 4.3.0f4, selection windows work now. :-)