Avoiding mesh intersection

I have a very simple setup with a board (plane with 4 walls, all are "thick") and a sphere. The problem Im seeing is that when I start the game, the sphere intersects with my board. This in turn means that forces I apply makes the movement very erratic. The board has a mesh collider, sphere has a.. well.. a sphere collider :)

If I replace the sphere with a cube, the intersection is more pronounced. Half of the cube passes thru my board, more or less.

Should I approach it differently? Should the meshes be optimized in some fashion?

set the initial position of the sphere to somewhere that don't penetrate any other collider. also there is a setting for the allowed amount of penetration called "min penetration before penalty" in edit/project settings/physics that means how much 2 collides can penetrate each other before going back. you should not set this value to numbers near zero but you can make colliders bigger to remove the visual effect if that is noticable. your current problem is about what i said first.