AWS S3 SDK PostObjectAsync not working on iOS

I’m using the AWS .NET SDK for Unity for uploading images into our S3 bucket. Using GetObjectAsync method seems to work fine and I can see the image loaded properly. However, using PostObjectAsync or PutObjectAsync does not seem to work when building for iOS. It does work when using the Editor or building for Android. I’ve seen a similar issue a year before and still exists up to now. Below are some of those I found:

I’ve tried their workaround but still to no avail. Have tried this but still no luck. Don’t know if only the UnityWebRequestWrapper.cs file should be changed.

Error message:

The request signature we calculated does not match the signature you provided. Check your key and signing method.

Have any of you out there experienced a similar case? Can you provide information or a solution to fix this?

Unity version: 2019.1.8f1

AWS .NET SDK version: Latest as of writing.

A big thank you in advance!

Fixed it by upgrading to Unity version 2019.2.3f1.

Unfortunately this didnt fix it for me. What fixed it for me is by adding the header reserved properties bypass fix for UnityWWWRequestFactory.cs