Bad Sprite Sheet Resolution in Unity

I have a sprite sheet open in Unity but it has bad resolution compared to the image I saved.

Here is my sprite sheet in Photoshop. It is saved as a PNG.

But here it is open in Unity Sprite editor. It has those rectangles on the image.

Ahhh, png. I have lots of problems with PNG and Unity (actually I think they are problems with Photoshop exporting PNG). However, this is normal. You need to select the PNG texture in Unity’s project folder, and select RGBA or Truecolor instead of Compressed. If that is configured properly, it will do this with a texture MIP MAP level of detail change. In working with 2D, I almost always disable the MIP MAPs generated. You will select the texture, again, and you may need to change it to an Advanced texture, and deselect the Generate Mipmaps checkbox.

EDIT: By the way, to bypass the crazy Photoshop PNG issues (not this one, but you may experience others), I would recommend integrating photoshop directly into your workflow. Just save the file as a photoshop file and import that file as a texture in Unity, if it fits in your workflow. If you experience other issues, you’ll have to use a different format. I mainly have problems with alpha channels and how photoshop exports (doesn’t export) them. When you save as a photoshop file, you can put a check next to “Alpha Channels” when saving.