Baked blender texture too small when in unity

I know im just missing something small.

Made a model in blender, baked the textures into one image. So far so good.

Export as a .fbx and bring into Unity. Wonderful.

Drag and drop the baked texture onto the model’s material, and it seems like it’s too small, in fact the baked image ‘tiles’ about 3 times. ARRRGGGHH!!

  • I did a render in Blender before exporting, it looked fine

  • My textures were baked as a 2048 x 2048 image in blender. Its file name is ‘bake001.fbx’

  • In Unity the name of the model’s material is ‘highrise’ (which is the name of one of the original textures which was baked)…if i apply the ‘highrise’ texture, it scales fine.

What have i done wrong?

Thank you for your time, (a frustrated) Tom :frowning:

(If i’ve not been clear, feel free to ask for further information :slight_smile: )

x-posted to ‘blender artists’…but i bet you guys can help before they do (totally DIDN’T say the same on ‘blender artists’)

select your model, check import settings, find ‘Materials’ block, change ‘Material Naming’ property. this should fix material’s names. feedback here if this doesn’t help.

All i had to do was delete the uv map that i wasn’t using in the ‘object data’.

Thank you ScroodgeM & WilliamLeu for your help :slight_smile: