Baked lightmaps not using full texture.

Hello! I’m having an issue with a mesh that i created, for some reason when I bake lights on it, the resulting bake only uses 1/4th of the image:

I don’t know why this is happening, I have the objects UVs unwrapped correctly, and even using Unity’s “Generate Lightmaps” function gives a similar result.

What’s weird is that other objects on the scene use the full texture correctly.
All objects are set to static and use lightmaps when baking.
These are my lighting settings:

Any help will be greatly appreciated!

Found a solution for anyone who might be interested in the future. Go to the MeshRenderer component of the static object/s you’re going to bake. Then find the value Lightmapping > Scale in Lightmap and increase the value as much as possible until a message pops up under the value that says “Scale bigger than atlas size”. And then you can bake and it will use nearly all the texture size.