Baking ambient color not possible?

When switching from realtime to baked global illumination it seems that enviorment lighting is ignored and is not baked into the lightmap.

To reproduce simply go to ‘Lighting’->‘Enviorment’->‘Enviorment Lighting’ and set the source to ‘Color’ and set the ambient color to pure white. Make sure that baked global illumination is disabled. The result should be a bright and somewhat flat scene which still gets color from the light sources.

However, as soon as you enable baked global illumination and bake the lights, the scene gets dark as if the ambient color was completely ignored.

Is there any way to bake lighting with the ambient color so the final result is the same as in realtime mode?

YES PLEASE! same Problem here! Can we please see an answer?