Basic Water shader error message

I have imported the Standard Assets. When I add water to my scene it is pink. I added the Prefabs for WaterProDaytime and Water(Basic) WaterBasicDaytime and both are pink.

Under Water(Basic) Shaders select the FXWaterBasic shader, in the Inspector > Imported Object > FX/Water(Basic)there are 4 errors listed:
‘unity_ObjectToWorld’ : undeclared identifier for opengl, d3d9, d3d11, d3d11_9x.

If I Open the code in MonoDevelop, the first line is a comment:

// Upgrade NOTE: replaced '_Object2World' with 'unity_ObjectToWorld'

unity_ObjectToWorld is only used on line 43:

float4 wpos = mul (unity_ObjectToWorld, v.vertex);

Using Unity personal (64bit) v 5.3.4f1

Any idea what causes this error and how to fix it?

I had the exact same problem that was resolved the same way. I am using 5.3.2 too.

Same problem and same resolution on 5.3.5p2, after upgrading from 5.3.2f1

Tank you very much guys. I just solve the problem.!!!

I was looking for this. Thank you. Adding this line “float4 wpos = mul (_Object2World, v.vertex);” actually fixed pink water problem :slight_smile:

I found an answer. The thing is that those things you have to change are present on multiple places so check that shading code thorougly.

I had to start the same project again and next time I uploaded same shaders everything worked well. Go figure…

gusy i have avrything i have copy paste yours and still not working what wrong have i done i changed (unity_ObjectToWorld, v.vertex; to (unity_Object2World, v.vertex; plz help :frowning: i apreciat forever